Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't destroy resources
#1
When I want to destroy a Natural Resource that's in my way I click on Destroy, but nothing happens. Self Destroy also dose not work.
Windows 10 Version 0.30
Reply
#2
Which natural resource is giving you the most trouble? Trees can seem to overlay. For trees, if you use the semi-transparent map view you are able to see how close the tree is to being fully deleted (the darker/more transparent = the closer to being destroyed). If it's other resources, it would still be helpful to know which type.
Join the Commonwealth of Zharnia!
Charter Code: CjYKOHvh
Reply
#3
If you haven't done a hard reload, do so. You may have loaded the game at time when the scripts were being modified. This can happen frequently when using the web version as it is the live development version. I tried it on 0.30.0 with several different colonies and the resources are removed with no issue.
Reply
#4
(03-21-2017, 10:19 AM)Patchdaddy Wrote: If you haven't done a hard reload, do so.  You may have loaded the game at time when the scripts were being modified.  This can happen frequently when using the web version as it is the live development version.  I tried it on 0.30.0 with several different colonies and the resources are removed with no issue.

How can I do a hard reload? I use the W10 App from the store. I tried closing it through the Task Manager and had a Load Data Packages message show up on restart, but the problem is still around. I couldn't reproduce it on a different machine either. The machine with trouble is a VM.

I have problems with all resources.
Reply
#5
If you open up the developer console and press refresh, it downloads everything like a first time resource.

I believe the "normal" way of doing that is by holding Control and pressing F5, but I could be wrong.
Reply
#6
My apologies. You said you were running version 0.30.0 of the game which is only available on the web at present, so I assumed incorrectly that you were using a web browser. Please double check your game version, it will be in the title screen as "Build v0.xx.0". The most current version for your platform in 0.29.0. If you are not currently running 0.29.0 then please upgrade. Running the game in a VM shouldn't have any effect. You may want to try uninstalling and then installing the game again. You can download the desktop version direct from here: https://market.ape-apps.com/my-colony.html. Before uninstalling the game, make backup copies of your colony(ies) so that you can restore them after you reinstall. The frequently asked questions page linked in my signature has instructions on how to make a backup of your colony.
Reply
#7
I do remember having that sort of bug with a pond water resource...it'd do the explosion FX but not disappear.

....i'd be fun because i could spam destory and the whole screen would fill up with explosions slowing the game down.
Reply
#8
(03-22-2017, 10:15 AM)Patchdaddy Wrote: My apologies.  You said you were running version 0.30.0 of the game which is only available on the web at present, so I assumed incorrectly that you were using a web browser.  Please double check your game version, it will be in the title screen as "Build v0.xx.0".  The most current version for your platform in 0.29.0.  If you are not currently running 0.29.0 then please upgrade.  Running the game in a VM shouldn't have any effect.  You may want to try uninstalling and then installing the game again.  You can download the desktop version direct from here:  https://market.ape-apps.com/my-colony.html.  Before uninstalling the game, make backup copies of your colony(ies) so that you can restore them after you reinstall.  The frequently asked questions page linked in my signature has instructions on how to make a backup of your colony.

It is v 0.30.0 W10 UWP. Reinstalling dose not fix it either, I think that save file has an issue when I start a new game it works.
Reply
#9
Send a copy of your save file to support@ape-apps.com for debugging. Make sure include a detailed description of the issue you are having.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Shoutbox

« archive

avatar
looks like im starting all over again....
avatar
tried looking but all im seeing is a long conversation about bugs....
avatar
If you scroll down a ways patchdaddy posted the link, I cant cause not sure how to on this tablet
avatar
Send the file to the dev would be my guess
avatar
no way to fix it?
avatar
You start over. Messing around, sorry. Smile
avatar
save just became corrupted as i hit 250k civs for independance, how do i fix my file?
avatar
hmm, entertain me
avatar
I found a little issue. Not sure if it's been discussed. But after you upgrade your capitol, and respond to mail by trying to send resources it defaults back to 500 maximum.
avatar
@nunez499 thankyou for the help. Is there any information on a how to within the forums? I have only been playing the game a few weeks had an issue with my tablet and had to reset back and lost all. Created a new game so its going better.
avatar
Rufus here. Liking the 'annex' feature. Freedonia has expanded to allow more aluminum and uramium production, as well as a portrait of our fearless leader
avatar
@Lordmommy when you become independent, you can create a new colony by using your own chartercode
avatar
Can anyone tell me where to look on how to create a sub colony and link the 2? Please?
avatar
Definitely rename your saves - that's a common mistake that causes older saves to be overwritten when someone makes a new colony.
avatar
It takes a while to get going on the forest planet. Good luck!
avatar
im thinking the earth-like planet might be the best because things progress more slowly so you can see a disaster approaching quicker....at least at the start.
avatar
darn...oh well.....a good enough reason to start a new colony and try new thing. like NOT using any aluminium for buildings. im trying the wood to charcoal to steel/gold the earthlike planet. but small. giving myself a little maybe doomed challenge
avatar
If the new colony saved as the same file, then yes, it would overwrite the old one.
avatar
hey quick question...if i have a colony with the same name...does it delete the older one......if so i may have lost my best colony. Tongue it was named beta-52 or something but saved as my-colony.mcz
avatar
Have fun!